Jump to content
  • 0

Every time I log in I'm told there's a new viewer update for the same update I already did.



3 answers to this question

Recommended Posts

  • 0

Performa a Clean Install with this version:



OK Do the following:

1) Reinstall SL again using the official version from Linden Lab. [be sure to do a clean install - Instructions are at the link below]

.... http://wiki.secondlife.com/wiki/Release_Notes/Second_Life_Release/

Here is the Windows 8 Manual System File cleanup procedure since it's not in the procedure above.

Windows 8 and Windows 8.1

.... 1) Open C:\Users\(PC Login Name)\AppData\Local and delete the contents of the SecondLife folder.
.... 2) Open C:\Users\(PC Login Name)\AppData\Roaming and delete the contents of the SecondLife folder.
.... 3) Uninstall Second Life using the Programs and Features tool in the Windows Control Panel.
.... 4) Download and install the latest release of the Second Life Viewer from http://secondlife.com/support/downloads/.

Note: (PC Login Name) is the Windows 8 User Account Login Name

If you can't see the files or folders described above:
.... 1) Using File Explorer navigate to -> Libraries / Computer / ( C: ) / Users /
.... 2) Press the Continue button to get permission to obtain permanent permission edit this directory.
.... 3) From the View drop-down menu option select Options & Change Folder & Search Options
.... 4) Select the View Tab
.... 5) Under the Hidden Files and Folders options click on the - O Show hidden files, folders & Drives radio button
.... 6) Push the Apply Button then the OK button.

2) Login using that Viewer and wait for a complete Login and Inventory rebuild.

3) Afterwards, you may use any viewer you prefer but I recommend a clean install of that viewer as well following their instructions.

  • Like 2
Link to comment
Share on other sites

  • 0

Okay, maybe this will work for you like it did for me. I'm using Windows 7, by the way.

Thanks to Oz Linden for pointing me in the right direction about the shortcut!

EDIT: Got ahead of myself again. A quicker fix than below:

1. Right-Click and select Properties for your shortcut(s) to Second Life.

2. In the window that comes up, under the Shortcut tab, look in the box labeled Target.

3. If has a part that says SecondLife.exe, change it to SecondLifeViewer.exe

4. That's it.


If that doesn't work, try this:

1. Install the update or let it install itself, but don't start the viewer yet.

2. Your shortcut to Second Life on your desktop or in your quick launch bar, etc? Delete it! (The one in your Start menu should be okay, you don't have to delete it)

3. Open the folder where Second Life is installed. C:\Program Files (x86)\SecondLifeViewer or similar.

4. Inside that folder there will be a bunch of files. Look for a shortcut (not the .exe etc) called "Second Life Viewer" - copy/paste that new shortcut to wherever you had the old one(s).

5. Now you can use the new shortcut like the old one.

If it works, you won't have to do a clean reinstall (be careful deleteing that folder in Local by the way, that's where your log files live!

Also, a side-effect I noticed that might be the tell for this problem: Launching from the old shortcut and then going to Help menu > About Second Life gave me this:


...instead of the usual about info.

After manually replacing the shortcut, it went back to normal.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...