Jump to content

Snapshot is compressed image of entire screen not dimensions set


Recommended Posts

Hello Everyone!  I am pretty sure I've just spent all day trying to find the answer to this problem.  Many apologies if one of you gives me a quick link to the answer.  I promise I tried to look. 


I used to be able to set the proportion of my photo (width x height) while looking at the whole screen.  If I wanted a square photo, the edges of my rectangular screen would grey out a little and I would see the square image that would be saved to disk.  On my computer, the image wold only be of the part that was not greyed out.


Now, if I set the proportion to anything less than the screen, the sides still grey out as if the picture was only going to be of the chosen dimension, but the image on my computer is of the entire screen compressed down to the dimensions I set.  Distorted and compressed.


This happens if I check or uncheck constrain proportions, if I check or uncheck High Resolution Snapshot to disk.


What I am doing is reducing the screen to the size of the photo I want to save, but that is very cumbersome as I usually like to take square photos.


Am I missing something.


Thank you so much =)

Link to comment
Share on other sites

Heya,

I just tried to get the same thing; opened my snapshot window - custom size - uncheck constrain proportions and manually entered values in width and height - I put 700. Then I refreshed the snapshot and saved it. It turned out normal, without distortions. I even made it so that my avi is in that grey area in the snapshot preview window and after saving it the avi was not in the saved snapshot. 

And I checked and don't have High res snapshots enabled, God knows when I disabled this lol

There is a thread on other forum that maybe helps you http://www.sluniverse.com/php/vb/general-sl-discussion/82645-photos-all-stretched-new-viewer.html

And check do you get the same problem with and without the ALM and when running the viewer on your entire screen or you resize it. Also make sure to refresh the snapshot, maybe even twice lol

Link to comment
Share on other sites

Thank you so much for the reply and the link!

I HAVE FOUND THE ANSWER!!  And it's not a good one!

The snapshot is CORRECT with Constrain Proportions off and any random numbers put in for width and height that are not equal to the size of the screen AS LONG AS the Advanced Lighting Model is unchecked!  When the Advanced Lighting Model (ALM) is checked, the snapshot is of the WHOLE screen (which is wider than it is tall) compressed to whatever size I set (i.e. 3000 x 3000)

This is really terrible and needs to be looked at and fixed since without ALM we cannot get the beautiful shadows.

So my next issue is:

I'll see if a JIRA was created

 

Link to comment
Share on other sites

Okay I played around a bit and got something kinda weird.... Can you try it and see what you get? 

Keep ALM and constrain proportions checked. Chose any custom size of your snapshot. Save it to disk to make sure you got the correct shot. Now:

  1. Uncheck constrain prop. and decrease the width of the shot, refresh and save. See what you get.
  2. Then again click constrain proportions, change the size. Refresh. Save to make sure you get correct snapshot.Then uncheck constrain proprtions but this time increase the height of the shot, refresh and save. See how it looks now.

In first case I got correct ratio even if the ALM is on and constrain prop. off, in 2nd one I got the wrong ratio.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

I've had the same problem. Thanks for your answer that  helped. I've found out that the ALM will not compress image as long as the Height (in Custom) is kept to 718 px or lower. Make it 719 and you get it compressed. Than, the solution is uncheking the ALM. Hopefully this bug will get fixed.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...