Jump to content

So out of curiosity (constant updates?)


AuriGrey
 Share

Recommended Posts

It seems to me that nearly every time I launch my SL viewer, it goes through an install package for an update.
I've noticed this before with other .exe's that were installed incorrectly - it's a very minor thing in this case, but it constantly wants to go through it and apply (I think the -exact same- update/s repeatedly?) updates.
Just making sure we haven't been getting crap tons of mini-updates recently and it's not just me. xP

Link to comment
Share on other sites


AuriGrey wrote:

It seems to me that nearly every time I launch my SL viewer, it goes through an install package for an update.

I've noticed this before with other .exe's that were installed incorrectly - it's a very minor thing in this case, but it constantly wants to go through it and apply (I think the -exact same- update/s repeatedly?) updates.

Just making sure we haven't been getting crap tons of mini-updates recently and it's not just me. xP

No, there should only have been one update recently - what's happening should be fixed by doing whatever you prevously did to fix the incorrectly installed .exe's.

Link to comment
Share on other sites

Others have run into this problem. Oz Linden pointed out in another thread the likely problem and what the Lab did that causes it.

The cause is from a directory/folder name change. SL previously was installed in a folder named: SecondLife. New versions are installed in one named: SecondLifeViewer.

If you use a self-made shortcut to start the SL Viewer it likely did not get updated and still points to the old folder. Thus, you keep starting the old viewer and it keeps updating the new new folder. It is an endless cycle.

Clean out your shortcuts and make new ones. That should solve the problem. If you are not into making shortcuts, delete all the SL shortcuts you use. Then reinstall the latest SL Viewer and let it make a new shortcut. Or there is a premade shortcut in the SecondLifeViewer folder you can copy.

I suggest you run the uninstall program for the old SL Viewer by navigating to the folder: C:\Program Files (x86)\SecondLife. Find uninst.exe and double click it. That should clean out the old stuff. When asked about removing everything, say NO.

Next install/reinstall the new SL Viewer to rebuild the common parts of the old and new viewers like registry entries that will get removed by running uninstall. Then re-pin your shortcuts.

Link to comment
Share on other sites

So they've cocked things up again, eh? Nothing new there then.

I rarely look in any sub-forums except the General Discussion one so this is a rare outing for me. I came to this one because of the very frequent updates I've been getting lately. They are not caused by the shortcut I use when starting the viewer, because I get updates auto-downloaded when I'm logged in, and a message each time. I've been getting those downloads and messages very frequently lately, even on consecutive days. For instance, not long before I logged off last night, I got the "We have downloaded..." message, so it was nothing to do with the shortcut used when starting the viewer. That's how all the updates have been arriving, and there have been a lot of them just lately. I'm assuming that they're putting updates out with fixes for the **bleep**-ups they made on yesterday's update, and so on and so on.

Link to comment
Share on other sites


Phil Deakins wrote:

 

They are not caused by the shortcut I use when starting the viewer, because I get updates auto-downloaded when I'm logged in, and a message each time. I've been getting those downloads and messages very frequently lately, even on consecutive days.

Because you get bugged with those constant "updates" it most likely is due to the shortcut.The executable was changed from "SecondLife.exe" to "SecondLifeViewer.exe". As Oz explained if you have copied the shortcut it will not be updated by the install program; that copied shortcut still points to "SecondLife.exe" instead of "SecondLifeViewer.exe". Oz said: "Unfortunately, the old executable was not removed as part of the upgrade." Therefore if your shortcut points to "SecondLife.exe" you will get bugged with the constant viewer updates daily because you are running the older version instead of the new one.

Check your shortcut as suggested by Oz and you should be ok:

http://community.secondlife.com/t5/Second-Life-Viewer/Second-Life-3-6-12-284506-Dec-4-2013-04-55-18-Keeps-downloading/m-p/2375155#M22105

 

PS.

I noticed that in my installation the shortcut (created by the install program - not copied by me) pointed to "SecondLifeViewer.exe" just as it should. However in the in the viewer installation folder there are:

"SecondLife.exe" and "SecondLifeViewer.exe"

 

Therefore it's worthwhile checking to which one your shortcut points to.

 

SecondLife.exe launches the earlier viewer version (in my computer it was version "Second Life 3.6.9").

SecondLifeViewer.exe launches the new version (in my computer it is version "Second Life 3.6.12").

 

Link to comment
Share on other sites

I'm about to turn in for the night but, coming back to the computer, I see that another update has been downloaded, which will install when I open the viewer tomorrow. It was downloaded after many hours of the viewer running and not when I ran the viewer - never when I run the viewer. So how can it be that.... ah. I get it now I'll change the shortcut tomorrow before logging in.

Considering that they've made such a stupid error, wouldn't you think that they'd be sensible enough to do another update to fix it? Idiots.

Link to comment
Share on other sites


Phil Deakins wrote:

I'm about to turn in for the night but, coming back to the computer, I see that another update has been downloaded, which will install when I open the viewer tomorrow. It was downloaded after many hours of the viewer running and not when I ran the viewer - never when I run the viewer. So how can it be that.... ah. I get it now I'll change the shortcut tomorrow before logging in.

Considering that they've made such a stupid error, wouldn't you think that they'd be sensible enough to do another update to fix it? Idiots.

G'night Phil, sleep well, and hopefully tomorrow will be a brand new shiny day where things will be more sensible (or not).

Link to comment
Share on other sites

Well I have recieved numerous  "Updates" recently that last a short while ago.   Linden labs needs to do more than tweak things.  Lag and rezzibg are now  almost unbearable.   Having been on SL 5 years it has never been so bad
When the next convention  is held - if ever - there will be many questions asked.   We need to vbe told what the problem is and what Linden Lab are doing to resolve it.   

0

  

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...