Jump to content

Mapping not holding on upload


Chic Aeon
 Share

Recommended Posts

beltnotmappingonupload.jpg

So ---

 

Have pretty toolbelt with ambient map. The ONLY part that uploads with the map is the hammer which was made long ago and imported.  The other sections (7 materials in the complete linked object) act like they have never been mapped (the color from one pixel thing). 

I am using the newest version of Blender which is NEW to me and that might be part of the issue. BUT I have been making other things without this problem.   The belt itself uses the solify modifier (applied) but there are some sections that aren't mapping (buckle for example) that don't have a solify modifier used.  8517 vertices in all.

Obviously I am overlooking something but have NO CLUE what it might be. So you really smart folks, I could use a hint or two -- or three LOL.

 

Thanks a bunch.  

 

EDIT: I also started out with an avatar blend file to get the size and shape for the belt area. It has "shape keys" in there somewhere and I have NO CLUE about shape keys as not something I normally use. The avatar that was connected to the shapes keys is of course not getting uploaded -- Still .

 

Link to comment
Share on other sites

OK. That may be it. My graphics card just died so on an ancient notebook but old graphics card is apparently in and I will test.   Oddly I noted that when I went to make the ambient map for "most" of the belt, I ALSO had one for the other material NOT on that map. "I" didn't do it so that was strange. But since it looked fine on the model I assumed it was OK.

BUT like that thread, the map that went with the hammer was fine and the other two did that one pixel thing. So I can remap and put them all on one OR upload as a linkset and then join maybe. Anyway a place to start so BIG THANKS. 

 

 

Link to comment
Share on other sites

OK. I separated the hammer from the belt and redid the mapping so that ALL the belts was on ONE map.

That did NOT fix the issue at all. I did a bunch of other stuff and tried different exports.  FINALLY it worked. Here is a photo of the export that worked in case someone else has this issue. I have never changed anything from the default exports so not sure how this got messed up.  And I am still not sure WHY it worked :D.   So obviously something simple that changed and that I had no clue about. Hopefully it won't be an issue all that often.

 

settingsthatworked.jpg

Link to comment
Share on other sites

Hello Chic. I was interested in your screenshot of the Blender export panel.

Now straight off, I myself definitely do not know/understand the why's and wherefore's of the way these things work; however I offer the following, anecdotally, as it were.

A week or so ago I was having a similar problem with an uploaded mesh that "did that one pixel thing". Now usually I only bother ticking the Selection Only box (and maybe the very last one, viz. Sort by Object name if I am doing a linkset). What sorted MY problem was ticking that Only Avtive UV layer box - something I had never troubled with previously.

Quite possibly, this does not relate directly to the problem you had ...

Link to comment
Share on other sites

Have you tried the Operator Presets for Second life ?

Blender has 2 presets, opne for Rigged Mesh, one for Static Mesh. The Presets can be found in the Selection box named "Operator Presets" at the very top of the export panel. I'd recommend you always use these presets. After all we made them for your convenience :matte-motes-sunglasses-1:

Link to comment
Share on other sites

Here is how it seems to work...

If you join objects, the combined object will have a set of UV maps consisting of one map for each distinct map name in the objects before they were joined. In each map, if an object had a map with that name before joining, that will be incorporated, with the coordinates unchanged, into the map of the same name in the combined object; if it did not, then all the vertices of the object will be set to 0,0 in that map of the joined object. In other words, the UV coordinates for each object will remain the same in any map for which it has a defined map, but for any maps it did not already have, it will be coalesced at 0,0. It is the coalesced maps that give the 1-pixel texturing.

Now the dae file - If the Active UV Map Only option is unchecked, the exporter will export all the UV maps of the joined object, but the SL uploader will only include one. In the experiments I did some time ago, that was always the last one in the file (this would happen if it read them sequentially and overwrote the previous one each time, although it's not really that simple). If the option is set, then, presumably, the dae file should only get the active UV map. However, in my Blender (2.71) it exports the Selected one, not the Active one*

You can select the active UV map in the UV Maps section of the Object Data tab of the Properties panel. This is shown in the picture. The maps are listed, and the small camera icon is the button for selecting the active map. It is shaded for the inactive maps, but clear for the active map. When it is active, it will be used in rendering (and baking?). It will also be displayed in the UV map edit window where you can see whether this map has proper or coalesced UV coordinates for selected vertices in this map. Here, the map with the green arrow is active, while the other two are inactive. Note that the map with the blue arrow is selected, but NOT active. You can rename the maps here (eg, before joining) by double clicking on their names.

uvm.png

So if you have a set of UV mapped objects you want to join, the best thing is to make sure the UV map you want to use for each has the same name (this is automatic if you have just the default map name for each object). You can ensure this by renaming them if it is required. Then the joined object will get a map with that name that has all the desired mappings. You can then delete any other UV maps in the joined object. Alternatively you can make sure you make the desired map active by clicking its camera AND selecting it, before exporting with the Active UV Map Only option (This is automatically selected if you choose an SL export preset, but that doesn't mean it makes the right map active!).

 *I assume this is a bug. I don't know if it has been corrected in later Blender versions. Meanwhile, some of the confusion people have experienced may be because of this. If you always leave the correct UV map both active and selected, you should be immune from this bug or its correction.

ETA - checked and discovered that it is selected, not active, map that gets exported in Blender 2.71 !!

ETA - see message from Gaia below, that the ambiguity will soon be removed by changing the option from "Active" to "Selected".

  • Like 1
Link to comment
Share on other sites


Drongle McMahon wrote:

ETA - checked and discovered that it is selected, not active, map that gets exported in Blender 2.71 !!

Indeed. It is the selected UV Map that is exported when this checkmark is set. This was wrong in the Label. Thanks for pointing this out.

Link to comment
Share on other sites

OK :D

You guys are smarter if not I.   But I did want to put in some notes for folks that may find this issue in the future.

MY workflow methods haven't changed but apparently Blender has made some changes and that was the issue. I also started with the avatar.blend file (for testing the shape of the belt) so some settings (I am thinking in export) may have been different than the defaults I normally use. And I will remember that export for SL option -- I typically don't use that.

 

Here is what I had:

The hammer was an older build imported and had its own existing map

The tool belt was newly made and had one map for the main portions of the belt (buckle, hooks etc) and one map for the pouch.

When I baked the ambient map for the main part of the belt it SEEMED to also bake the map for the pouch automatically.  I was surprised at that and that had never happened for me. 

When I uploaded that first time (one object) only the hammer retained the mapping (there would have been three maps associated with this single object doing things the old 2.64 way.

After reading Drongle's info I separated the hammer from the belt and then remapped the belt so that there was only a single map.Eventually I got it to take the mapping. By now (day 3 of the project but no issues until the texture thing happened) I was bleary so details are mushy. I did thankfully take that screenshot. I am not sure WHICH of the boxes actually needed to be checked at this point but I will reread all this info a few times. Some of us just aren't a Blenderfied as you pro folks :D.

I was actually uploading this on OpenSim (tried in IW which has different rules than other OS grids too). I do plan to upload here but I am not a fan of the beta grid so usually work there to test. I suspect that the issues would be the same.

SO -- I will try the SL upload feature should this happen again. I have made several fairly complex items with multiple maps since I installed 2.73 and this was the first with issues. Perhaps I uploaded them as linksets and not a single object. So for me I think just changing my mapping and uploading methods will "fix" this.

 

I do like the interface changes in 2.73 :D

 

toolbeltclose.png

 

Link to comment
Share on other sites

OK. Middle of my night but up and working and awake :D.  So I think I get it. I just made a simple bookcase with two maps and it was fine. So the issue with my belt project was apparently the hammer which I imported into the scene. Luckily I don't do that often.

And I am in Blender 2.73 where it still seems to be occurring.

I really like the changes in the interface but SO not happy with the way unwrapping is -- making a long and narrow board into the same sized squares. Maybe there is a setting I am missing on this but it works very differently than what I have always had :(   So doing a lot of "project from view" LOL,

 

Anyway. Smarter and thank you for your help. Sure this will help others also!

Link to comment
Share on other sites

An even easier way to combine objects and end up with a single uv is to use the Texture Atlas add-on, which, if you've activated it in User Preference>Add-Ons, will appear as a sub-palette in the render palette.

As follows:

Select the objects you wish to combine.

In the Texture Atlas Subpalette press the plus sign to create a group from the selected objects .  You can give it a new name or accept the one given. 

Select:  "NO UNWRAP"  and

Select: "START MANUAL UNWRAP"

A merged duplicate of your selected objects will appear in the 3d scene and in the item list.  The original objects you merged will be in the items list set to hidden visibility.  They can be deleted or saved to another layer.  

This merged object duplicate you create will have a single UV- all the uvs islands remain in their original positions and the original uv set names/versions will have been deleted.

Edited to add:  I'm adding this in response to the video re: combining objects posted by Gaia.

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...