Jump to content

Texturing Sculpted Plant Prims


Recommended Posts

I have a number of sculpted plant prims that I use.  I have two that are single plant prims, one is an 8 panel sculpt, the other is a 16 panel.  When I apply a plant texture to the 8 panel prim, there is a distinct line above the prim where the panels criss cross.  So it looks like a large asterisk hovering above my plant.  At first, I thought it was the texture having a line like that at the top, or the alpha not being "complete" up there, but I have tried many different textures from many creators and they are all like that. Now I feel like it is the sculpt map I'm using.

Does anybody know what causes that and if there is a way to counteract it?

Also, on the 16 panel prim, when I apply the textures, they look great, but when I cam back, the prim morphs from a round, 16 panel prim, to an upside down cone.  It's the strangest thing.  Then, when I zoom back to normal, it changes back to the way it's supposed to be.  I thought maybe it was because of zooming out when camera locked on it, so I just walked a fair distance away from it, turned around and looked and sure enough, I had a field of upside down cones over where I should have a field of flowers and ferns. 

So what causes THAT and how can I fix it?

Any help you can give would be greatly appreciated!  :smileywink:

Link to comment
Share on other sites

What you're seeing is actually the bottom of the texture, wrapping around.

To solve it, be sure to keep a small margin of clear on all four sides of the plant in the texture. 2-4 px on each edge should do it in most cases. If I'm working to a 512 texture, it's easy to just build my textures at 500x500, then add 6px on each side. with 256x256 textures (a good size for plants btw) I work to 250x250, then add 3px on all 4 sides.

 

As for your sculpts changing shapes.. that's because they haven't been optimized for lower levels of detail. The fix isn't so easy here. Either make new sculpts that are better optimized, or add a 50% grey layer at 50% transparency to the sculpt map image itself (that will double the size the the bounding box, making the sculpt smaller within the invisible box..).. or you can opt to crank down your viewer's LOD sensitivity. I don't personally reccommend that last option, because many people's video hardware are barely up to SL as it is.

Here's instructions for cranking your LOD setting... if you want to risk it.


  1. Show the “Advanced” menu with Ctrl-Alt-D, or Opt-Ctrl-D on a Mac.
  2. Select “debug settings” near the bottom.
  3. In the blank space, copy and paste the word:
    RenderVolumeLODFactor
  4. The recommend setting it as high as 4 to get all your sculpts looking as the maker intended.
Quoted from
.

 

  • Like 2
Link to comment
Share on other sites

 


Winter Ventura wrote:

What you're seeing is actually the bottom of the texture, wrapping around.

Ah!  Okay...thank you for that Miss Winter!  I don't have the textures on my hard drive (I purchase all mine) so should I change the vertical repeats in some way to compensate for the wrap around?

 

Link to comment
Share on other sites

 


Jaylin Wytchwood wrote:

Regarding the sculpy being rendered as blob, check your LOD / Level of Detail:

1. Show the “Advanced” menu with Ctrl-Alt-D

2. Select “debug settings” near the bottom.

3. In the blank space, copy and paste the word:

RenderVolumeLODFactor

4. Set this to 4

 

 

 

I will check this when I get inworld, Jaylin, but I think it already IS set to 4.  I'll double check though. 

 

Link to comment
Share on other sites

 


Marcus Hancroft wrote:

 

Jaylin Wytchwood wrote:

Regarding the sculpy being rendered as blob, check your LOD / Level of Detail:

1. Show the “Advanced” menu with Ctrl-Alt-D

2. Select “debug settings” near the bottom.

3. In the blank space, copy and paste the word:

RenderVolumeLODFactor

4. Set this to 4

 

 

 

I will check this when I get inworld, Jaylin, but I think it already IS set to 4.  I'll double check though. 

 

Just checked and it was set to 2.0, not 4.0.  Just changed it.  Now to see if that solved the problem!

Yep!  That worked!  So the cone problem is fixed now...at least for ME!  Thank you, Jaylin!

 

Link to comment
Share on other sites

 


Rolig Loon wrote:

Yes, you should be able to change the repeats to something just slightly under 1.0 (try 0.98) to get rid of the wraparaound issue.  This is a common solution for dealing with the floating X over plants and ghost lines at the ends of hair prims.

Ah!  Thank you so much for that, Miss Rolig!  I'll give that a try! 

 

Link to comment
Share on other sites

 


Jaylin Wytchwood wrote:

Regarding the sculpy being rendered as blob, check your LOD / Level of Detail:

1. Show the “Advanced” menu with Ctrl-Alt-D

2. Select “debug settings” near the bottom.

3. In the blank space, copy and paste the word:

RenderVolumeLODFactor

4. Set this to 4

 

This will solve the problem for you, in your viewer. But others who don't have their LOD factor set to 4 will see the sculpt still in the way the OP descripted.

 

Link to comment
Share on other sites

My own sculpted plants don't have this problem, and you'll see why when you see them; from no angle do they appear either flat or made from flat things; they look like plants from the top, and even from inside the limits of the prim.

I already offer some for free, and I'll give more to those who ask niceley.

If anyone cares, I'll be improving and expanding my sculpted alpha plant line in the near future; the stems portions will be better.

Link to comment
Share on other sites

 


Josh Susanto wrote:

My own sculpted plants don't have this problem, and you'll see why when you see them; from no angle do they appear either flat or made from flat things; they look like plants from the top, and even from inside the limits of the prim.

I already offer some for free, and I'll give more to those who ask niceley.

If anyone cares, I'll be improving and expanding my sculpted alpha plant line in the near future; the stems portions will be better.

 

Howdy, Josh!

I would LOVE to see those actually!  Where can I see them and get the ones you already have done?

*ON EDIT - Found you on Marketplace!  I can't wait to see them!  :)

Link to comment
Share on other sites

Well the trick is basically to fold the sculpt over inside itself so that it has no invisible interior surface. 

As this is acheived by mirroring, the alpha is also a mirror.

Mirroring an asymmetrical alpha leaf onto a mirrored helical cone (for example) produces both a back and a front to the leaf which map perfectly back to front. 

Done correctly, the effect is essentially the same each time the leaf is duplicated horizonatally.

Try changing the number of horizontal repeats by using the arrow and see what happens.

Link to comment
Share on other sites

  • 1 year later...

I know its an old thread but THANK YOU Winter because now I can just copy & paste this thread URL to the increasing numbers of customers that assume it's a texture glitch

I have spent days & upload fees trying to delete lines that are invisible to the naked eye in Photoshop and in SL on a standard prim!

Thanks for sharing! 

Link to comment
Share on other sites

This "marrying" of plant textures made by one creator to plant sculpt maps created by another creator causes much frustration to users and creators alike.

The only way you can be 100% sure a texture will work on a sculpt is if both were created by the same person and sold together.

It's a bit of pot luck and a lot of texture tweaking otherwise :)

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...