Jump to content

ubuntu 14.04: libGL error: unable to load driver: r600_dri.so ...


Recommended Posts

hello community

an older ACER laptop was lying around so i installed ubuntu 14.04 and wanted to run friestorm viewer on it. I did install the 32 bit firestorm 'Phoenix_FirestormOS-Release_i686_4.7.3.47323'.

 

But it wont run ... make some errors if i start from terminal in the unpacked firestorm directory with './firestorm'.

It crates a lot of lines but finally comes that:

----

 

Context: creating window 1024x738x32
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast
The program 'do-not-directly-run-firestorm-bin' received an X Window System error.

-----

 

i duckduckgoed a bit around and i guess is a driver problem with the graphic driver lib because maybe i need opensource driver ...

i m very thankfull for any help - it will be cool to run sl on linux heheheh.

oberon

 

Link to comment
Share on other sites

Have you installed proprietary/non-free graphics drivers? If not I would recomend that you do. Use your ubuntu package manager to find them

As for running the viewer app itself, I`ve never bothered installing a viewer with install.sh, or using the terminal. The method that works for me is find the firestorm executable in the unpacked folder, right click it, choose "run" or "execute" and it should start the viewer.

After the first run you should then see that a shortcut has been added to your apps menu under "games" or "internet"

Hope that helps and let us know how you get on :smileyhappy:

 

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...