Jump to content

.DAE File Issues: Blender to Second Life


Travis Lytham
 Share

Recommended Posts

When trying to upload a tree i made in Blender 2.75a. At very beinging when upload the Tree a Red X pops up saying i am missing Triangles and Vertices (Note: I made sure it was Mesh and Subdivision in the actual tree), wich later disappeared when file fully loaded i guess. Then the tree in secondlife  showed up on the Preview image as the tree but  With no texture when i put texture in it, and afterwards when trying to calculate it  a Error pops up saying, MAV_Block_Missing.

What can i do to fix this situation?

Link to comment
Share on other sites

There are many ways this error can be caused. However, your description of the delay in seeing the red cross disappear suggests you have a very large number of triangles. In that case, you might consider whether it could be the problem described in message 6 in this thread. If it is, the simple fix is to reduce the number of triangles in your mesh. That's always a good idea anyway.

Link to comment
Share on other sites

Thank you for that intel. I gave it a try but still no fixes. I could had just too much leaves on the tree. IDK. I'll try one more time but if it doesnt work. SL and Mesh tree may not fully get along. lol. It was at 30k in the polies and I got it down to 5k. Didnt work. Then down to 4k.Still didnt work just got a messages saying: MAV_Block_Missing Upload_invalidAsset

Link to comment
Share on other sites

If this is from the sapling tree generator in Blender then I doubt you will have much luck. Even the simple ones come in as very "primmy" on this grid. I have uploaded them fine on the beta grid (mine didn't have a LOT of leaves but bigger ones which works better -- you might try that. And my had the solidify modifier on the leaves as I hated that odd thing of one sided leaves).  

Make sure you have your tree mapped (UV unwrapped) also. Not clear if you did that. I let the auto function unwrap the leaves getting a whole page of tiny leaves and that worked fine. I did the trunk and larger limbs by hand.

If I remember correctly (it has been awhile) there are levels of complexity in the beginning choices. I think going over 2 is a BAD idea -- only if I am remembering right.

Still, even with a very simple tree with large and not to terribly many leaves, a small tree was 7 land impact. If it got to more than people height the LI went way up.

 

I have these all over my sim in Opensim with no noticable lag at all. "There" they are one land impact (:D) but of course that doesn't help HERE.   So while interesting, not practical in SL.

 

 

 

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

×
×
  • Create New...